2
$\begingroup$

This formatting of this answer seems to overlap with the right sidebar:

Is anyone aware how can this be fixed (by, say, forcing MathJax to create a new line) automatically?

| |
$\endgroup$
  • $\begingroup$ It is what expected. Hilder uses 3 columns that can not be fir there. Latex, by default overflows and warns about them. It is the writers' response to correct/fix the overflows. $\endgroup$ – kelalaka Dec 12 '19 at 9:17
  • $\begingroup$ I've made some updates, see the post. $\endgroup$ – kelalaka Dec 12 '19 at 9:22
  • $\begingroup$ $\hskip -2.7em \color{black}{\Rule{2em}{1.8em}{2em}}$ Also, you can do stuff like this: $\rlap{\color{red}{\Rule{35em}{1em}{0.75em}}}$ $\endgroup$ – forest Dec 12 '19 at 9:24
1
$\begingroup$

This bug is years old. It was first reported on the main Meta site, after which a bug report was made in MathJax. Unfortunately, the bug report is still open. There's not much that can be done about it.

| |
$\endgroup$
  • 1
    $\begingroup$ @kelalaka Like that? Changed 200em to 35em. $\endgroup$ – forest Dec 12 '19 at 9:24
  • $\begingroup$ That is better, at least I don't have a horizontal scrollbar. $\endgroup$ – kelalaka Dec 12 '19 at 9:26
1
$\begingroup$

It seems that replacing $\begin{align} with $$\begin{align} - and adding a dollar sign at the end as well - adds a horizontal scrollbar. That means that the user needs to scroll a bit, but that seems a better option than overflowing into text for formulas that don't fit (without correct flow control). Obviously a better flow control would be the final solution, but this seems to be a good workaround. This workaround should be preferred to letting the text overflow, as that may well produce unreadable results. Comment here if the workaround does not work for you, and please include browser and environment information if you do.

Unfortunately, like many sites, SE doesn't allow full width browsing, so we will always be a bit space-limited until we at least get an option to enable it.

In the mean time, I've added the first thumbs up to the initial bug report on GitHub, please add your "votes" if you agree with it. This is not something SE is likely to be able to fix on their own after all.

| |
$\endgroup$
  • 1
    $\begingroup$ I found that we can use <sub> math goes here</sub>. That makes smaller but works. $\endgroup$ – kelalaka Jan 30 at 9:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .